[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: isdn pap config



Well, the first thing to do is start simple, and then build your
configuration after you establish a successful connection.

The most common problem with failing to connect is authentication. However,
let's just look at your configuration a bit:

It seems you have to BRI intefaces. Are you using both of them? If so, I'd
recommend to work with one for the time being.

This is how I'd configure my BRI 0/0 interface:

conf t

 isdn switch-type basic-net3

 int bri0/0
  encap ppp
  dialer pool-member 1
  ppp auth pap
  ppp multilink

 int dialer1
  ip address negotiated
  encap ppp
  dialer-remote name kasesecob
  dialer string 0031232100
  dialer load-threshold 127 either
  dialer pool 1
  dialer-group 1
  ppp auth pap
  ppp multilink

 ip route 0.0.0.0 0.0.0.0 dialer 1
 dialer-list 1 protocol ip permit

There, that should be a very basic configuration to get you up and running,
or to, at least, get you to troubleshoot your problem without having to
worry about too many configuration variables you may have.

Keep your mind off any other configuration parameteres for now, such as the
compression scheme you used [STAC] and the extra dialer profiles.

Some good debug tools to use:

debug ppp authentication
debug ppp events
debug ppp negotiation
debug ppp multilink
debug dialer

Please be careful when using these debugging tools, they can easily increase
your CPU load. I suggest you use only two at a time.

Regards,

Mark Tinka - CCNA
Network Engineer
Africa Online Uganda
5th Floor, Commercial Plaza
7 Kampala Rd,
Tel:   +256-41-258143
Fax:   +256-41-258144
E-mail: mtinka at africaonline.co.ug
Web:     www.africaonline.co.ug


-----Original Message-----
From: owner-afnog at afnog.org [mailto:owner-afnog at afnog.org]On Behalf Of
Richard Mikisa
Sent: Monday, March 31, 2003 8:34 PM
To: afnog at afnog.org
Subject: isdn pap config


Hi all'

We are trying to set up an isdn dialup with a cisco 2611. The cisco is
supposed to dial up into a patton access server. We have to use PAP
authentication.. We however are able to make the call but it then fails
because for some reason, the patton doesn't get the caller id. Can some
one help. Below is the router config that we are using.



kasesecob#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname kasesecob
!
enable password bugo
!
username kasese password 0 one2net
!
!
!
!
ip subnet-zero
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0/0
 description ISDN B Channels 1&2 for Dialer
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-net3
 no fair-queue
 compress stac
 ppp authentication pap
 ppp multilink
!
interface Ethernet0/1
 no ip address
 no ip directed-broadcast
!
interface BRI0/1
 description ISDN B Channels 3&4 for Dialer
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-net3
 no fair-queue
 compress stac
 ppp authentication pap
 ppp multilink
!
interface Dialer1
 ip address negotiated
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name kasesecob
 dialer idle-timeout 30000
 dialer string 0031232100
 dialer load-threshold 127 either
 dialer-group 1
ppp authentication pap
 ppp multilink
!
interface Dialer3
 ip address negotiated
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name kasese
 dialer idle-timeout 30000
 dialer string 0031232100
 dialer load-threshold 127 either
 dialer-group 1
 ppp authentication pap
 ppp multilink
!
interface Dialer12
 no ip address
 no ip directed-broadcast
 no cdp enable
!
no ip classless
ip route 0.0.0.0 0.0.0.0 169.254.0.1
ip route 99.98.97.0 255.255.255.0 192.168.12.5
ip route 99.98.97.0 255.255.255.0 192.168.12.5
ip route 128.0.0.0 255.255.0.0 192.168.12.5
ip route 130.0.0.0 255.255.255.0 192.168.12.5
ip route 169.254.0.0 255.255.255.0 169.254.0.1
no ip http server
!
access-list 100 permit ip any any
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
snmp-server engineID local 00000009020000B0646CD2E0
snmp-server community public RO
banner motd ^C
This is KCCL's Private Network.Unauthiorized users please logout
immedieately ^C

!
line con 0
 transport input none
line aux 0
line vty 0 4
 password nguli
 login
!
end

--
Cheers
Richard


-----
This is the afnog mailing list, managed by Majordomo 1.94.5

To send a message to this list, e-mail afnog at afnog.org
To send a request to majordomo, e-mail majordomo at afnog.org and put
your request in the body of the message (i.e use "help" for help)

This list is maintained by owner-afnog at afnog.org





-----
This is the afnog mailing list, managed by Majordomo 1.94.5

To send a message to this list, e-mail afnog at afnog.org
To send a request to majordomo, e-mail majordomo at afnog.org and put
your request in the body of the message (i.e use "help" for help)

This list is maintained by owner-afnog at afnog.org